{"cve":"CVE-2022-34870","nvd":{"published":"2022-10-25T17:15:53.683","modified":"2026-06-17T04:51:04.353","status":"Modified","description":"Apache Geode versions up to 1.15.0 are vulnerable to a Cross-Site Scripting (XSS) via data injection when using Pulse web application to view Region entries.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","score":5.4},"cwes":["CWE-79"],"references":["http://www.openwall.com/lists/oss-security/2022/10/24/3","https://lists.apache.org/thread/zltlr7f2ymr2m6jj54k4z0c4foos5fwx","http://www.openwall.com/lists/oss-security/2022/10/24/3","https://lists.apache.org/thread/zltlr7f2ymr2m6jj54k4z0c4foos5fwx"],"products":["apache:geode"],"source":"nvd","synced_at":"2026-10-19T21:37:08.729216836+00:00"},"epss":{"cve":"CVE-2022-34870","score":0.01375,"percentile":0.72034,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-373r-9mg8-3jc4","url":"https://osv.dev/vulnerability/GHSA-373r-9mg8-3jc4","summary":"Apache Geode vulnerable to Cross-Site Scripting","modified":"2023-11-08T04:09:49.317060Z","packages":[{"ecosystem":"Maven","name":"org.apache.geode:geode-core","purl":"pkg:maven/org.apache.geode/geode-core","ranges":["<1.15.1"],"fixed":["1.15.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}