{"cve":"CVE-2022-34182","nvd":{"published":"2022-06-23T17:15:15.990","modified":"2026-06-17T04:49:51.557","status":"Modified","description":"Jenkins Nested View Plugin 1.20 through 1.25 (both inclusive) does not escape search parameters, resulting in a reflected cross-site scripting (XSS) vulnerability.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","score":6.1},"cwes":["CWE-79"],"references":["https://www.jenkins.io/security/advisory/2022-06-22/#SECURITY-2768","https://www.jenkins.io/security/advisory/2022-06-22/#SECURITY-2768"],"products":["jenkins:nested_view"],"source":"nvd","synced_at":"2026-10-19T21:32:39.174919249+00:00"},"epss":{"cve":"CVE-2022-34182","score":0.00986,"percentile":0.62399,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-h642-5h74-3x9c","url":"https://osv.dev/vulnerability/GHSA-h642-5h74-3x9c","summary":"Reflected Cross-site Scripting in Jenkins Nested View Plugin","modified":"2023-11-08T04:09:42.801098Z","packages":[{"ecosystem":"Maven","name":"org.jenkins-ci.plugins:nested-view","purl":"pkg:maven/org.jenkins-ci.plugins/nested-view","ranges":[">=1.20 <1.26"],"fixed":["1.26"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}