{"cve":"CVE-2022-34112","nvd":{"published":"2022-07-22T23:15:08.053","modified":"2026-06-17T04:49:44.720","status":"Analyzed","description":"An access control issue in the component /api/plugin/uninstall Dataease v1.11.1 allows attackers to arbitrarily uninstall the plugin, a right normally reserved for the administrator.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N","score":6.5},"cwes":["CWE-732"],"references":["https://github.com/dataease/dataease/issues/2429","https://github.com/dataease/dataease/issues/2429"],"products":["dataease:dataease"],"source":"nvd","synced_at":"2026-10-19T21:33:44.859608815+00:00"},"epss":{"cve":"CVE-2022-34112","score":0.00613,"percentile":0.49394,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-c2pj-rr68-pw94","url":"https://osv.dev/vulnerability/GHSA-c2pj-rr68-pw94","summary":"Dataease before 1.11.2 access control issue allows attackers to arbitrarily uninstall plugin","modified":"2023-11-08T04:09:41.550727Z","packages":[{"ecosystem":"Maven","name":"io.dataease:dataease-plugin-common","purl":"pkg:maven/io.dataease/dataease-plugin-common","ranges":["<1.11.2"],"fixed":["1.11.2"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}