{"cve":"CVE-2022-33683","nvd":{"published":"2022-09-23T10:15:10.353","modified":"2026-06-17T04:49:14.943","status":"Modified","description":"Apache Pulsar Brokers and Proxies create an internal Pulsar Admin Client that does not verify peer TLS certificates, even when tlsAllowInsecureConnection is disabled via configuration. The Pulsar Admin Client's intra-cluster and geo-replication HTTPS connections are vulnerable to man in the middle attacks, which could leak authentication data, configuration data, and any other data sent by these clients. An attacker can only take advantage of this vulnerability by taking control of a machine 'between' the client and the server. The attacker must then actively manipulate traffic to perform the attack. This issue affects Apache Pulsar Broker and Proxy versions 2.7.0 to 2.7.4; 2.8.0 to 2.8.3; 2.9.0 to 2.9.2; 2.10.0; 2.6.4 and earlier.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N","score":5.9},"cwes":["CWE-295"],"references":["https://lists.apache.org/thread/42v5rsxj36r3nhfxhmhb2x12r5jmvx3x","https://lists.apache.org/thread/42v5rsxj36r3nhfxhmhb2x12r5jmvx3x"],"products":["apache:pulsar"],"source":"nvd","synced_at":"2026-10-19T21:36:05.460296998+00:00"},"epss":{"cve":"CVE-2022-33683","score":0.00682,"percentile":0.525,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-j3qw-g67q-7m64","url":"https://osv.dev/vulnerability/GHSA-j3qw-g67q-7m64","summary":"Apache Pulsar Brokers and Proxies vulnerable to Improper Certificate Validation","modified":"2023-11-08T04:09:40.396494Z","packages":[{"ecosystem":"Maven","name":"org.apache.pulsar:pulsar-broker","purl":"pkg:maven/org.apache.pulsar/pulsar-broker","ranges":["<2.7.5"],"fixed":["2.7.5"]},{"ecosystem":"Maven","name":"org.apache.pulsar:pulsar-proxy","purl":"pkg:maven/org.apache.pulsar/pulsar-proxy","ranges":["<2.7.5"],"fixed":["2.7.5"]},{"ecosystem":"Maven","name":"org.apache.pulsar:pulsar-broker","purl":"pkg:maven/org.apache.pulsar/pulsar-broker","ranges":[">=2.8.0 <2.8.4"],"fixed":["2.8.4"]},{"ecosystem":"Maven","name":"org.apache.pulsar:pulsar-proxy","purl":"pkg:maven/org.apache.pulsar/pulsar-proxy","ranges":[">=2.8.0 <2.8.4"],"fixed":["2.8.4"]},{"ecosystem":"Maven","name":"org.apache.pulsar:pulsar-broker","purl":"pkg:maven/org.apache.pulsar/pulsar-broker","ranges":[">=2.9.0 <2.9.3"],"fixed":["2.9.3"]},{"ecosystem":"Maven","name":"org.apache.pulsar:pulsar-proxy","purl":"pkg:maven/org.apache.pulsar/pulsar-proxy","ranges":[">=2.9.0 <2.9.3"],"fixed":["2.9.3"]},{"ecosystem":"Maven","name":"org.apache.pulsar:pulsar-broker","purl":"pkg:maven/org.apache.pulsar/pulsar-broker","ranges":[">=2.10.0 <2.10.1"],"fixed":["2.10.1"]},{"ecosystem":"Maven","name":"org.apache.pulsar:pulsar-proxy","purl":"pkg:maven/org.apache.pulsar/pulsar-proxy","ranges":[">=2.10.0 <2.10.1"],"fixed":["2.10.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}