{"cve":"CVE-2022-30241","nvd":{"published":"2022-05-04T18:15:10.037","modified":"2026-06-17T04:43:19.983","status":"Modified","description":"The jquery.json-viewer library through 1.4.0 for Node.js does not properly escape characters such as < in a JSON object, as demonstrated by a SCRIPT element.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","score":6.1},"cwes":["CWE-79"],"references":["https://github.com/abodelot/jquery.json-viewer/pull/26","https://www.npmjs.com/package/jquery.json-viewer","https://github.com/abodelot/jquery.json-viewer/pull/26","https://www.npmjs.com/package/jquery.json-viewer"],"products":["jquery_json-viewer_project:jquery_json-viewer"],"source":"nvd","synced_at":"2026-10-19T21:30:03.577988018+00:00"},"epss":{"cve":"CVE-2022-30241","score":0.00715,"percentile":0.53763,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-qp2q-6h9j-jg2r","url":"https://osv.dev/vulnerability/GHSA-qp2q-6h9j-jg2r","summary":"Cross-site Scripting in jquery.json-viewer","modified":"2023-11-08T04:09:17.137315Z","packages":[{"ecosystem":"npm","name":"jquery.json-viewer","purl":"pkg:npm/jquery.json-viewer","ranges":["<1.5.0"],"fixed":["1.5.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}