{"cve":"CVE-2022-29241","nvd":{"published":"2022-06-14T21:15:15.900","modified":"2026-06-17T04:39:53.943","status":"Modified","description":"Jupyter Server provides the backend (i.e. the core services, APIs, and REST endpoints) for Jupyter web applications like Jupyter Notebook. Prior to version 1.17.1, if notebook server is started with a value of `root_dir` that contains the starting user's home directory, then the underlying REST API can be used to leak the access token assigned at start time by guessing/brute forcing the PID of the jupyter server. While this requires an authenticated user session, this URL can be used from a cross-site scripting payload or from a hooked or otherwise compromised browser to leak this access token to a malicious third party. This token can be used along with the REST API to interact with Jupyter services/notebooks such as modifying or overwriting critical files, such as .bashrc or .ssh/authorized_keys, allowing a malicious user to read potentially sensitive data and possibly gain control of the impacted system. This issue is patched in version 1.17.1.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","score":8.8},"cwes":["CWE-200"],"references":["https://github.com/jupyter-server/jupyter_server/security/advisories/GHSA-q874-g24w-4q9g","https://github.com/jupyter-server/jupyter_server/security/advisories/GHSA-q874-g24w-4q9g"],"products":["jupyter:jupyter_server"],"source":"nvd","synced_at":"2026-10-19T21:32:39.174919249+00:00"},"epss":{"cve":"CVE-2022-29241","score":0.00971,"percentile":0.61925,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-q874-g24w-4q9g","url":"https://osv.dev/vulnerability/GHSA-q874-g24w-4q9g","summary":"Jupyter server Token bruteforcing","modified":"2026-09-10T03:49:49.383978105Z","packages":[{"ecosystem":"PyPI","name":"jupyter-server","purl":"pkg:pypi/jupyter-server","ranges":["<1.17.1"],"fixed":["1.17.1"]},{"ecosystem":"PyPI","name":"jupyter-server","purl":"pkg:pypi/jupyter-server","ranges":[">=2.0.0a0 <2.0.0a1"],"fixed":["2.0.0a1"]}]},{"id":"PYSEC-2022-211","url":"https://osv.dev/vulnerability/PYSEC-2022-211","summary":"","modified":"2023-11-08T04:09:11.919120Z","packages":[{"ecosystem":"PyPI","name":"jupyter-server","purl":"pkg:pypi/jupyter-server","ranges":["<1.17.0"],"fixed":["1.17.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}