{"cve":"CVE-2022-29050","nvd":{"published":"2022-04-12T20:15:09.760","modified":"2026-06-17T04:39:30.350","status":"Modified","description":"A cross-site request forgery (CSRF) vulnerability in Jenkins Publish Over FTP Plugin 1.16 and earlier allows attackers to connect to an FTP server using attacker-specified credentials.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","score":8.8},"cwes":["CWE-352"],"references":["https://www.jenkins.io/security/advisory/2022-04-12/#SECURITY-2321","https://www.jenkins.io/security/advisory/2022-04-12/#SECURITY-2321"],"products":["jenkins:publish_over_ftp"],"source":"nvd","synced_at":"2026-10-19T21:30:03.577988018+00:00"},"epss":{"cve":"CVE-2022-29050","score":0.00726,"percentile":0.54122,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-6w39-qhmq-g8cp","url":"https://osv.dev/vulnerability/GHSA-6w39-qhmq-g8cp","summary":"CSRF vulnerability in Jenkins Publish Over FTP Plugin","modified":"2023-11-08T04:09:07.641684Z","packages":[{"ecosystem":"Maven","name":"org.jenkins-ci.plugins:publish-over-ftp","purl":"pkg:maven/org.jenkins-ci.plugins/publish-over-ftp","ranges":["<1.17"],"fixed":["1.17"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}