{"cve":"CVE-2022-28732","nvd":{"published":"2022-08-04T07:15:07.597","modified":"2026-06-17T04:38:56.103","status":"Modified","description":"A carefully crafted request on WeblogPlugin could trigger an XSS vulnerability on Apache JSPWiki, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. Apache JSPWiki users should upgrade to 2.11.3 or later.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","score":6.1},"cwes":["CWE-79"],"references":["https://jspwiki-wiki.apache.org/Wiki.jsp?page=CVE-2022-28732","https://jspwiki-wiki.apache.org/Wiki.jsp?page=CVE-2022-28732"],"products":["apache:jspwiki"],"source":"nvd","synced_at":"2026-10-19T21:34:18.502168378+00:00"},"epss":{"cve":"CVE-2022-28732","score":0.82827,"percentile":0.99671,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-hph8-29xw-qfxx","url":"https://osv.dev/vulnerability/GHSA-hph8-29xw-qfxx","summary":"Apache JSPWiki XSS due to crafted request in WeblogPlugin","modified":"2023-11-08T04:09:05.301193Z","packages":[{"ecosystem":"Maven","name":"org.apache.jspwiki:jspwiki-main","purl":"pkg:maven/org.apache.jspwiki/jspwiki-main","ranges":["<2.11.3"],"fixed":["2.11.3"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}