{"cve":"CVE-2022-25979","nvd":{"published":"2023-01-31T05:15:11.927","modified":"2026-06-17T04:34:32.927","status":"Modified","description":"Versions of the package jsuites before 5.0.1 are vulnerable to Cross-site Scripting (XSS) due to improper user-input sanitization in the Editor() function.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","score":6.1},"cwes":["CWE-79"],"references":["https://github.com/jsuites/jsuites/commit/b31770d5fe91684a00177f629aab933139c32d9f","https://github.com/jsuites/jsuites/issues/134","https://security.snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-3253331","https://security.snyk.io/vuln/SNYK-JS-JSUITES-3226764","https://github.com/jsuites/jsuites/commit/b31770d5fe91684a00177f629aab933139c32d9f"],"products":["jsuites:jsuites"],"source":"nvd","synced_at":"2026-10-19T21:37:38.595364862+00:00"},"epss":{"cve":"CVE-2022-25979","score":0.00617,"percentile":0.49573,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-r4hg-4cpq-q57c","url":"https://osv.dev/vulnerability/GHSA-r4hg-4cpq-q57c","summary":"jSuites subect to Cross-site Scripting","modified":"2023-11-08T04:08:53.125833Z","packages":[{"ecosystem":"npm","name":"jsuites","purl":"pkg:npm/jsuites","ranges":["<5.0.1"],"fixed":["5.0.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}