{"cve":"CVE-2022-24760","nvd":{"published":"2022-03-12T00:15:08.593","modified":"2026-06-17T04:32:27.420","status":"Modified","description":"Parse Server is an open source http web server backend. In versions prior to 4.10.7 there is a Remote Code Execution (RCE) vulnerability in Parse Server. This vulnerability affects Parse Server in the default configuration with MongoDB. The main weakness that leads to RCE is the Prototype Pollution vulnerable code in the file `DatabaseController.js`, so it is likely to affect Postgres and any other database backend as well. This vulnerability has been confirmed on Linux (Ubuntu) and Windows. Users are advised to upgrade as soon as possible. The only known workaround is to manually patch your installation with code referenced at the source GHSA-p6h4-93qp-jhcm.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H","score":10.0},"cwes":["CWE-1321","CWE-74"],"references":["https://github.com/parse-community/parse-server/commit/886bfd7cac69496e3f73d4bb536f0eec3cba0e4d","https://github.com/parse-community/parse-server/security/advisories/GHSA-p6h4-93qp-jhcm","https://www.huntr.dev/bounties/ac24b343-e7da-4bc7-ab38-4f4f5cc9d099/","https://github.com/parse-community/parse-server/commit/886bfd7cac69496e3f73d4bb536f0eec3cba0e4d","https://github.com/parse-community/parse-server/security/advisories/GHSA-p6h4-93qp-jhcm"],"products":["parseplatform:parse-server"],"source":"nvd","synced_at":"2026-10-19T21:29:06.454770966+00:00"},"epss":{"cve":"CVE-2022-24760","score":0.49362,"percentile":0.9889,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-p6h4-93qp-jhcm","url":"https://osv.dev/vulnerability/GHSA-p6h4-93qp-jhcm","summary":"Command injection in Parse Server through prototype pollution","modified":"2023-12-06T01:02:05.184263Z","packages":[{"ecosystem":"npm","name":"parse-server","purl":"pkg:npm/parse-server","ranges":["<4.10.7"],"fixed":["4.10.7"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}