{"cve":"CVE-2022-23568","nvd":{"published":"2022-02-03T12:15:08.177","modified":"2026-06-17T04:30:22.633","status":"Modified","description":"Tensorflow is an Open Source Machine Learning Framework. The implementation of `AddManySparseToTensorsMap` is vulnerable to an integer overflow which results in a `CHECK`-fail when building new `TensorShape` objects (so, an assert failure based denial of service). We are missing some validation on the shapes of the input tensors as well as directly constructing a large `TensorShape` with user-provided dimensions. The fix will be included in TensorFlow 2.8.0. We will also cherrypick this commit on TensorFlow 2.7.1, TensorFlow 2.6.3, and TensorFlow 2.5.3, as these are also affected and still in supported range.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H","score":6.5},"cwes":["CWE-190"],"references":["https://github.com/tensorflow/tensorflow/blob/5100e359aef5c8021f2e71c7b986420b85ce7b3d/tensorflow/core/kernels/sparse_tensors_map_ops.cc","https://github.com/tensorflow/tensorflow/commit/a68f68061e263a88321c104a6c911fe5598050a8","https://github.com/tensorflow/tensorflow/commit/b51b82fe65ebace4475e3c54eb089c18a4403f1c","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-6445-fm66-fvq2","https://github.com/tensorflow/tensorflow/blob/5100e359aef5c8021f2e71c7b986420b85ce7b3d/tensorflow/core/kernels/sparse_tensors_map_ops.cc"],"products":["google:tensorflow"],"source":"nvd","synced_at":"2026-10-19T21:27:20.926095847+00:00"},"epss":{"cve":"CVE-2022-23568","score":0.00807,"percentile":0.56835,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-6445-fm66-fvq2","url":"https://osv.dev/vulnerability/GHSA-6445-fm66-fvq2","summary":"Integer overflows in Tensorflow","modified":"2026-09-10T03:49:11.797179699Z","packages":[{"ecosystem":"PyPI","name":"tensorflow","purl":"pkg:pypi/tensorflow","ranges":["<2.5.3"],"fixed":["2.5.3"]},{"ecosystem":"PyPI","name":"tensorflow","purl":"pkg:pypi/tensorflow","ranges":[">=2.6.0 <2.6.3"],"fixed":["2.6.3"]},{"ecosystem":"PyPI","name":"tensorflow","purl":"pkg:pypi/tensorflow","ranges":[">=2.7.0 <2.7.1"],"fixed":["2.7.1"]},{"ecosystem":"PyPI","name":"tensorflow-cpu","purl":"pkg:pypi/tensorflow-cpu","ranges":["<2.5.3"],"fixed":["2.5.3"]},{"ecosystem":"PyPI","name":"tensorflow-cpu","purl":"pkg:pypi/tensorflow-cpu","ranges":[">=2.6.0 <2.6.3"],"fixed":["2.6.3"]},{"ecosystem":"PyPI","name":"tensorflow-cpu","purl":"pkg:pypi/tensorflow-cpu","ranges":[">=2.7.0 <2.7.1"],"fixed":["2.7.1"]},{"ecosystem":"PyPI","name":"tensorflow-gpu","purl":"pkg:pypi/tensorflow-gpu","ranges":["<2.5.3"],"fixed":["2.5.3"]},{"ecosystem":"PyPI","name":"tensorflow-gpu","purl":"pkg:pypi/tensorflow-gpu","ranges":[">=2.6.0 <2.6.3"],"fixed":["2.6.3"]},{"ecosystem":"PyPI","name":"tensorflow-gpu","purl":"pkg:pypi/tensorflow-gpu","ranges":[">=2.7.0 <2.7.1"],"fixed":["2.7.1"]}]},{"id":"PYSEC-2022-132","url":"https://osv.dev/vulnerability/PYSEC-2022-132","summary":"","modified":"2026-07-13T16:42:32.091992149Z","packages":[{"ecosystem":"PyPI","name":"tensorflow-gpu","purl":"pkg:pypi/tensorflow-gpu","ranges":["<2.5.3",">=2.6.0 <2.6.3"],"fixed":["2.5.3","2.6.3"]}]},{"id":"PYSEC-2022-77","url":"https://osv.dev/vulnerability/PYSEC-2022-77","summary":"","modified":"2026-07-13T16:42:32.091992149Z","packages":[{"ecosystem":"PyPI","name":"tensorflow-cpu","purl":"pkg:pypi/tensorflow-cpu","ranges":["<2.5.3",">=2.6.0 <2.6.3"],"fixed":["2.5.3","2.6.3"]}]},{"id":"PYSEC-2026-3114","url":"https://osv.dev/vulnerability/PYSEC-2026-3114","summary":"Integer overflows in Tensorflow","modified":"2026-07-13T16:42:32.091992149Z","packages":[{"ecosystem":"PyPI","name":"tensorflow","purl":"pkg:pypi/tensorflow","ranges":["<2.5.3",">=2.6.0 <2.6.3",">=2.7.0 <2.7.1"],"fixed":["2.5.3","2.6.3","2.7.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}