{"cve":"CVE-2022-2309","nvd":{"published":"2022-07-05T10:15:08.763","modified":"2026-06-17T04:41:40.237","status":"Modified","description":"NULL Pointer Dereference allows attackers to cause a denial of service (or application crash). This only applies when lxml is used together with libxml2 2.9.10 through 2.9.14. libxml2 2.9.9 and earlier are not affected. It allows triggering crashes through forged input data, given a vulnerable code sequence in the application. The vulnerability is caused by the iterwalk function (also used by the canonicalize function). Such code shouldn't be in wide-spread use, given that parsing + iterwalk would usually be replaced with the more efficient iterparse function. However, an XML converter that serialises to C14N would also be vulnerable, for example, and there are legitimate use cases for this code sequence. If untrusted input is received (also remotely) and processed via iterwalk function, a crash can be triggered.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","score":7.5},"cwes":["CWE-476"],"references":["https://github.com/lxml/lxml/commit/86368e9cf70a0ad23cccd5ee32de847149af0c6f","https://huntr.dev/bounties/8264e74f-edda-4c40-9956-49de635105ba","https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/HGYC6L7ENH5VEGN3YWFBYMGKX6WNS7HZ/","https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/URHHSIBTPTALXMECRLAC2EVDNAFSR5NO/","https://security.gentoo.org/glsa/202208-06"],"products":["fedoraproject:fedora","lxml:lxml"],"source":"nvd","synced_at":"2026-10-19T21:33:44.859608815+00:00"},"epss":{"cve":"CVE-2022-2309","score":0.02448,"percentile":0.8437,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-wrxv-2j5q-m38w","url":"https://osv.dev/vulnerability/GHSA-wrxv-2j5q-m38w","summary":"lxml NULL Pointer Dereference allows attackers to cause a denial of service","modified":"2025-11-04T20:44:22.372909Z","packages":[{"ecosystem":"PyPI","name":"lxml","purl":"pkg:pypi/lxml","ranges":["<4.9.1"],"fixed":["4.9.1"]}]},{"id":"PYSEC-2022-230","url":"https://osv.dev/vulnerability/PYSEC-2022-230","summary":"","modified":"2023-11-08T04:08:16.338038Z","packages":[{"ecosystem":"PyPI","name":"lxml","purl":"pkg:pypi/lxml","ranges":["<4.9.1"],"fixed":["4.9.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}