{"cve":"CVE-2022-1812","nvd":{"published":"2023-01-14T14:15:08.953","modified":"2026-06-17T04:23:09.490","status":"Modified","description":"Integer Overflow or Wraparound in GitHub repository publify/publify prior to 9.2.10.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8},"cwes":["CWE-190"],"references":["https://github.com/publify/publify/commit/29a5837c29620e33857d7a5afce01384e3f8e41a","https://huntr.dev/bounties/17d86a50-265c-4ec8-9592-0bd909ddc8f3","https://github.com/publify/publify/commit/29a5837c29620e33857d7a5afce01384e3f8e41a","https://huntr.dev/bounties/17d86a50-265c-4ec8-9592-0bd909ddc8f3"],"products":["publify_project:publify"],"source":"nvd","synced_at":"2026-10-19T21:37:34.931465858+00:00"},"epss":{"cve":"CVE-2022-1812","score":0.30778,"percentile":0.98248,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-rc42-jghf-vr8f","url":"https://osv.dev/vulnerability/GHSA-rc42-jghf-vr8f","summary":"Integer overflow in publify_core","modified":"2023-12-06T01:01:53.108113Z","packages":[{"ecosystem":"RubyGems","name":"publify_core","purl":"pkg:gem/publify_core","ranges":["<9.2.10"],"fixed":["9.2.10"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}