{"cve":"CVE-2022-0086","nvd":{"published":"2022-01-04T18:15:08.257","modified":"2026-06-17T04:19:57.083","status":"Modified","description":"uppy is vulnerable to Server-Side Request Forgery (SSRF)","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8},"cwes":["CWE-918"],"references":["https://github.com/transloadit/uppy/commit/fc137e30a2a3102eb191141f280d5de20dacdf8f","https://huntr.dev/bounties/c1c03ef6-3f18-4976-a9ad-08c251279122","https://github.com/transloadit/uppy/commit/fc137e30a2a3102eb191141f280d5de20dacdf8f","https://huntr.dev/bounties/c1c03ef6-3f18-4976-a9ad-08c251279122"],"products":["transloadit:uppy"],"source":"nvd","synced_at":"2026-10-19T21:26:33.761856376+00:00"},"epss":{"cve":"CVE-2022-0086","score":0.01246,"percentile":0.69328,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-x8rq-rc7x-5fg5","url":"https://osv.dev/vulnerability/GHSA-x8rq-rc7x-5fg5","summary":"uppy's companion module is vulnerable to Server-Side Request Forgery (SSRF)","modified":"2025-12-22T18:10:38.554016Z","packages":[{"ecosystem":"npm","name":"@uppy/companion","purl":"pkg:npm/%40uppy/companion","ranges":["<3.1.5"],"fixed":["3.1.5"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}