{"cve":"CVE-2021-44550","nvd":{"published":"2022-02-24T15:15:24.067","modified":"2026-06-17T04:12:33.417","status":"Modified","description":"An Incorrect Access Control vulnerability exists in CoreNLP 4.3.2 via the classifier in NERServlet.java (lines 158 and 159).","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8},"cwes":["CWE-74"],"references":["https://github.com/stanfordnlp/CoreNLP/issues/1222","https://github.com/stanfordnlp/CoreNLP/issues/1222"],"products":["stanford:corenlp"],"source":"nvd","synced_at":"2026-10-19T21:28:04.509275555+00:00"},"epss":{"cve":"CVE-2021-44550","score":0.01294,"percentile":0.70324,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-x2p8-rgfm-qw3v","url":"https://osv.dev/vulnerability/GHSA-x2p8-rgfm-qw3v","summary":"Access Control vulnerability within CoreNLP","modified":"2023-11-08T04:07:17.412828Z","packages":[{"ecosystem":"Maven","name":"edu.stanford.nlp:stanford-corenlp","purl":"pkg:maven/edu.stanford.nlp/stanford-corenlp","ranges":["<4.4.0"],"fixed":["4.4.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}