{"cve":"CVE-2021-4326","nvd":{"published":"2023-03-01T08:15:10.187","modified":"2026-06-17T04:19:30.700","status":"Modified","description":"A vulnerability in Imperative framework which allows already-privileged local actors to execute arbitrary shell commands via plugin install/update commands, or maliciously formed environment variables. Impacts Zowe CLI.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","score":7.8},"cwes":[],"references":["https://github.com/zowe/imperative/","https://github.com/zowe/imperative/"],"products":["linuxfoundation:zowe"],"source":"nvd","synced_at":"2026-10-19T21:37:41.955480748+00:00"},"epss":{"cve":"CVE-2021-4326","score":0.00255,"percentile":0.17108,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-6q8m-42qq-64r7","url":"https://osv.dev/vulnerability/GHSA-6q8m-42qq-64r7","summary":"Imperative CLI vulnerable to Command Injection","modified":"2023-11-08T04:07:09.297630Z","packages":[{"ecosystem":"npm","name":"@zowe/imperative","purl":"pkg:npm/%40zowe/imperative","ranges":[">=5.0.0 <5.7.1"],"fixed":["5.7.1"]},{"ecosystem":"npm","name":"@zowe/imperative","purl":"pkg:npm/%40zowe/imperative","ranges":["<4.18.10"],"fixed":["4.18.10"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}