{"cve":"CVE-2021-42648","nvd":{"published":"2022-05-11T18:15:23.097","modified":"2026-06-17T04:09:54.870","status":"Modified","description":"Cross-site scripting (XSS) vulnerability exists in Coder Code-Server before 3.12.0, allows attackers to execute arbitrary code via crafted URL.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","score":6.1},"cwes":["CWE-79"],"references":["https://github.com/cdr/code-server/issues/4355","https://github.com/cdr/code-server/issues/4355"],"products":["coder:code-server"],"source":"nvd","synced_at":"2026-10-19T21:31:59.322382750+00:00"},"epss":{"cve":"CVE-2021-42648","score":0.00869,"percentile":0.58777,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-2gp3-6c9p-jp7w","url":"https://osv.dev/vulnerability/GHSA-2gp3-6c9p-jp7w","summary":"Cross site scripting in code-server","modified":"2026-09-10T03:49:07.202549818Z","packages":[{"ecosystem":"npm","name":"code-server","purl":"pkg:npm/code-server","ranges":["<3.12.0"],"fixed":["3.12.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}