{"cve":"CVE-2021-41275","nvd":{"published":"2021-11-17T20:15:10.527","modified":"2026-06-17T04:08:13.250","status":"Modified","description":"spree_auth_devise is an open source library which provides authentication and authorization services for use with the Spree storefront framework by using an underlying Devise authentication framework. In affected versions spree_auth_devise is subject to a CSRF vulnerability that allows user account takeover. All applications using any version of the frontend component of spree_auth_devise are affected if protect_from_forgery method is both: Executed whether as: A before_action callback (the default). A prepend_before_action (option prepend: true given) before the :load_object hook in Spree::UserController (most likely order to find). Configured to use :null_session or :reset_session strategies (:null_session is the default in case the no strategy is given, but rails --new generated skeleton use :exception). Users are advised to update their spree_auth_devise gem. For users unable to update it may be possible to change your strategy to :exception. Please see the linked GHSA for more workaround details. ### Impact CSRF vulnerability that allows user account takeover. All applications using any version of the frontend component of `spree_auth_devise` are affected if `protect_from_forgery` method is both: * Executed whether as: * A before_action callback (the default) * A prepend_before_action (option prepend: true given) before the :load_object hook in Spree::UserController (most likely order to find). * Configured to use :null_session or :reset_session strategies (:null_session is the default in case the no strategy is given, but rails --new generated skeleton use :exception). That means that applications that haven't been configured differently from what it's generated with Rails aren't affected. Thanks @waiting-for-dev for reporting and providing a patch �� ### Patches Spree 4.3 users should update to spree_auth_devise 4.4.1 Spree 4.2 users should update to spree_auth_devise 4.2.1 ### Workarounds If possible, change your strategy to :exception: ```ruby class ApplicationController < ActionController::Base protect_from_forgery with: :exception end ``` Add the following to`config/application.rb `to at least run the `:exception` strategy on the affected controller: ```ruby config.after_initialize do Spree::UsersController.protect_from_forgery with: :exception end ``` ### References https://github.com/solidusio/solidus_auth_devise/security/advisories/GHSA-xm34-v85h-9pg2","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","score":8.8},"cwes":["CWE-352"],"references":["https://github.com/spree/spree_auth_devise/commit/adf6ed4cd94d66091776b5febd4ff3767362de63","https://github.com/spree/spree_auth_devise/security/advisories/GHSA-26xx-m4q2-xhq8","https://github.com/spree/spree_auth_devise/commit/adf6ed4cd94d66091776b5febd4ff3767362de63","https://github.com/spree/spree_auth_devise/security/advisories/GHSA-26xx-m4q2-xhq8"],"products":["spreecommerce:spree_auth_devise"],"source":"nvd","synced_at":"2026-10-19T21:25:41.256909649+00:00"},"epss":{"cve":"CVE-2021-41275","score":0.00646,"percentile":0.50964,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-26xx-m4q2-xhq8","url":"https://osv.dev/vulnerability/GHSA-26xx-m4q2-xhq8","summary":"Spree Auth Devise vulnerability allows for authentication bypass through CSRF weakness","modified":"2026-07-08T06:29:30.052441152Z","packages":[{"ecosystem":"RubyGems","name":"spree_auth_devise","purl":"pkg:gem/spree_auth_devise","ranges":[">=4.3.0 <4.4.1"],"fixed":["4.4.1"]},{"ecosystem":"RubyGems","name":"spree_auth_devise","purl":"pkg:gem/spree_auth_devise","ranges":[">=4.2.0 <4.2.1"],"fixed":["4.2.1"]},{"ecosystem":"RubyGems","name":"spree_auth_devise","purl":"pkg:gem/spree_auth_devise","ranges":[">=4.1.0 <4.1.1"],"fixed":["4.1.1"]},{"ecosystem":"RubyGems","name":"spree_auth_devise","purl":"pkg:gem/spree_auth_devise","ranges":["<4.0.1"],"fixed":["4.0.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}