{"cve":"CVE-2021-41201","nvd":{"published":"2021-11-05T20:15:08.097","modified":"2026-06-17T04:08:05.050","status":"Modified","description":"TensorFlow is an open source platform for machine learning. In affeced versions during execution, `EinsumHelper::ParseEquation()` is supposed to set the flags in `input_has_ellipsis` vector and `*output_has_ellipsis` boolean to indicate whether there is ellipsis in the corresponding inputs and output. However, the code only changes these flags to `true` and never assigns `false`. This results in unitialized variable access if callers assume that `EinsumHelper::ParseEquation()` always sets these flags. The fix will be included in TensorFlow 2.7.0. We will also cherrypick this commit on TensorFlow 2.6.1, TensorFlow 2.5.2, and TensorFlow 2.4.4, as these are also affected and still in supported range.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","score":7.8},"cwes":["CWE-824"],"references":["https://github.com/tensorflow/tensorflow/commit/f09caa532b6e1ac8d2aa61b7832c78c5b79300c6","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-j86v-p27c-73fm","https://github.com/tensorflow/tensorflow/commit/f09caa532b6e1ac8d2aa61b7832c78c5b79300c6","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-j86v-p27c-73fm"],"products":["google:tensorflow"],"source":"nvd","synced_at":"2026-10-19T21:24:39.218183596+00:00"},"epss":{"cve":"CVE-2021-41201","score":0.00249,"percentile":0.16249,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-j86v-p27c-73fm","url":"https://osv.dev/vulnerability/GHSA-j86v-p27c-73fm","summary":"Unitialized access in `EinsumHelper::ParseEquation`","modified":"2026-07-08T06:28:21.332208764Z","packages":[{"ecosystem":"PyPI","name":"tensorflow","purl":"pkg:pypi/tensorflow","ranges":[">=2.6.0 <2.6.1"],"fixed":["2.6.1"]},{"ecosystem":"PyPI","name":"tensorflow","purl":"pkg:pypi/tensorflow","ranges":[">=2.5.0 <2.5.2"],"fixed":["2.5.2"]},{"ecosystem":"PyPI","name":"tensorflow","purl":"pkg:pypi/tensorflow","ranges":["<2.4.4"],"fixed":["2.4.4"]},{"ecosystem":"PyPI","name":"tensorflow-cpu","purl":"pkg:pypi/tensorflow-cpu","ranges":[">=2.6.0 <2.6.1"],"fixed":["2.6.1"]},{"ecosystem":"PyPI","name":"tensorflow-cpu","purl":"pkg:pypi/tensorflow-cpu","ranges":[">=2.5.0 <2.5.2"],"fixed":["2.5.2"]},{"ecosystem":"PyPI","name":"tensorflow-cpu","purl":"pkg:pypi/tensorflow-cpu","ranges":["<2.4.4"],"fixed":["2.4.4"]},{"ecosystem":"PyPI","name":"tensorflow-gpu","purl":"pkg:pypi/tensorflow-gpu","ranges":[">=2.6.0 <2.6.1"],"fixed":["2.6.1"]},{"ecosystem":"PyPI","name":"tensorflow-gpu","purl":"pkg:pypi/tensorflow-gpu","ranges":[">=2.5.0 <2.5.2"],"fixed":["2.5.2"]},{"ecosystem":"PyPI","name":"tensorflow-gpu","purl":"pkg:pypi/tensorflow-gpu","ranges":["<2.4.4"],"fixed":["2.4.4"]}]},{"id":"PYSEC-2021-394","url":"https://osv.dev/vulnerability/PYSEC-2021-394","summary":"","modified":"2023-12-06T01:01:33.809004Z","packages":[{"ecosystem":"PyPI","name":"tensorflow","purl":"pkg:pypi/tensorflow","ranges":["<2.4.4",">=2.5.0 <2.5.2",">=2.6.0 <2.6.1",">=2.7.0rc0 <2.7.0"],"fixed":["2.4.4","2.5.2","2.6.1","2.7.0"]}]},{"id":"PYSEC-2021-611","url":"https://osv.dev/vulnerability/PYSEC-2021-611","summary":"","modified":"2023-12-06T01:01:33.809004Z","packages":[{"ecosystem":"PyPI","name":"tensorflow-cpu","purl":"pkg:pypi/tensorflow-cpu","ranges":["<2.4.4",">=2.5.0 <2.5.2",">=2.6.0 <2.6.1",">=2.7.0rc0 <2.7.0"],"fixed":["2.4.4","2.5.2","2.6.1","2.7.0"]}]},{"id":"PYSEC-2021-809","url":"https://osv.dev/vulnerability/PYSEC-2021-809","summary":"","modified":"2023-12-06T01:01:33.809004Z","packages":[{"ecosystem":"PyPI","name":"tensorflow-gpu","purl":"pkg:pypi/tensorflow-gpu","ranges":["<2.4.4",">=2.5.0 <2.5.2",">=2.6.0 <2.6.1",">=2.7.0rc0 <2.7.0"],"fixed":["2.4.4","2.5.2","2.6.1","2.7.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}