{"cve":"CVE-2021-41098","nvd":{"published":"2021-09-27T20:15:07.397","modified":"2026-06-17T04:07:52.307","status":"Modified","description":"Nokogiri is a Rubygem providing HTML, XML, SAX, and Reader parsers with XPath and CSS selector support. In Nokogiri v1.12.4 and earlier, on JRuby only, the SAX parser resolves external entities by default. Users of Nokogiri on JRuby who parse untrusted documents using any of these classes are affected: Nokogiri::XML::SAX::Parse, Nokogiri::HTML4::SAX::Parser or its alias Nokogiri::HTML::SAX::Parser, Nokogiri::XML::SAX::PushParser, and Nokogiri::HTML4::SAX::PushParser or its alias Nokogiri::HTML::SAX::PushParser. JRuby users should upgrade to Nokogiri v1.12.5 or later to receive a patch for this issue. There are no workarounds available for v1.12.4 or earlier. CRuby users are not affected.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","score":7.5},"cwes":["CWE-611"],"references":["https://github.com/sparklemotion/nokogiri/commit/5bf729ff3cc84709ee3c3248c981584088bf9f6d","https://github.com/sparklemotion/nokogiri/security/advisories/GHSA-2rr5-8q37-2w7h","https://github.com/sparklemotion/nokogiri/commit/5bf729ff3cc84709ee3c3248c981584088bf9f6d","https://github.com/sparklemotion/nokogiri/security/advisories/GHSA-2rr5-8q37-2w7h"],"products":["nokogiri:nokogiri"],"source":"nvd","synced_at":"2026-10-19T21:23:41.316049955+00:00"},"epss":{"cve":"CVE-2021-41098","score":0.0146,"percentile":0.73559,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-2rr5-8q37-2w7h","url":"https://osv.dev/vulnerability/GHSA-2rr5-8q37-2w7h","summary":"Improper Restriction of XML External Entity Reference (XXE) in Nokogiri on JRuby","modified":"2026-07-08T06:28:52.471678359Z","packages":[{"ecosystem":"RubyGems","name":"nokogiri","purl":"pkg:gem/nokogiri","ranges":["<1.12.5"],"fixed":["1.12.5"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}