{"cve":"CVE-2021-39229","nvd":{"published":"2021-09-20T22:15:07.530","modified":"2026-06-17T04:03:21.583","status":"Modified","description":"Apprise is an open source library which allows you to send a notification to almost all of the most popular notification services available. In affected versions users who use Apprise granting them access to the IFTTT plugin (which just comes out of the box) are subject to a denial of service attack on an inefficient regular expression. The vulnerable regular expression is [here](https://github.com/caronc/apprise/blob/0007eade20934ddef0aba38b8f1aad980cfff253/apprise/plugins/NotifyIFTTT.py#L356-L359). The problem has been patched in release version 0.9.5.1. Users who are unable to upgrade are advised to remove `apprise/plugins/NotifyIFTTT.py` to eliminate the service.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","score":7.5},"cwes":["CWE-400"],"references":["https://github.com/caronc/apprise/blob/0007eade20934ddef0aba38b8f1aad980cfff253/apprise/plugins/NotifyIFTTT.py#L356-L359","https://github.com/caronc/apprise/pull/436","https://github.com/caronc/apprise/security/advisories/GHSA-qhmp-h54x-38qr","https://github.com/caronc/apprise/blob/0007eade20934ddef0aba38b8f1aad980cfff253/apprise/plugins/NotifyIFTTT.py#L356-L359","https://github.com/caronc/apprise/pull/436"],"products":["nuxref:apprise"],"source":"nvd","synced_at":"2026-10-19T21:23:41.316049955+00:00"},"epss":{"cve":"CVE-2021-39229","score":0.01891,"percentile":0.79582,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-qhmp-h54x-38qr","url":"https://osv.dev/vulnerability/GHSA-qhmp-h54x-38qr","summary":"Apprise vulnerable to regex injection with IFTTT Plugin","modified":"2026-07-08T06:28:03.764141266Z","packages":[{"ecosystem":"PyPI","name":"apprise","purl":"pkg:pypi/apprise","ranges":["<0.9.5.1"],"fixed":["0.9.5.1"]}]},{"id":"PYSEC-2021-327","url":"https://osv.dev/vulnerability/PYSEC-2021-327","summary":"","modified":"2023-11-08T04:06:34.460870Z","packages":[{"ecosystem":"PyPI","name":"apprise","purl":"pkg:pypi/apprise","ranges":["<0.9.5.1"],"fixed":["0.9.5.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}