{"cve":"CVE-2021-3914","nvd":{"published":"2022-08-25T20:15:09.363","modified":"2026-06-17T04:05:58.850","status":"Modified","description":"It was found that the smallrye health metrics UI component did not properly sanitize some user inputs. An attacker could use this flaw to conduct cross-site scripting attacks.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","score":6.1},"cwes":["CWE-79"],"references":["https://access.redhat.com/security/cve/CVE-2021-3914","https://bugzilla.redhat.com/show_bug.cgi?id=2018015","https://access.redhat.com/security/cve/CVE-2021-3914","https://bugzilla.redhat.com/show_bug.cgi?id=2018015"],"products":["redhat:build_of_quarkus","redhat:openshift_application_runtimes","redhat:smallrye_health"],"source":"nvd","synced_at":"2026-10-19T21:35:14.992143698+00:00"},"epss":{"cve":"CVE-2021-3914","score":0.00523,"percentile":0.44399,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-pvc3-wvxr-7cmf","url":"https://osv.dev/vulnerability/GHSA-pvc3-wvxr-7cmf","summary":"SmallRye Health UI Cross-site Scripting vulnerability","modified":"2024-02-16T08:01:16.156999Z","packages":[{"ecosystem":"Maven","name":"io.smallrye:smallrye-health-ui","purl":"pkg:maven/io.smallrye/smallrye-health-ui","ranges":["<3.1.2"],"fixed":["3.1.2"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}