{"cve":"CVE-2021-39132","nvd":{"published":"2021-08-30T20:15:07.660","modified":"2026-06-17T04:03:07.777","status":"Modified","description":"Rundeck is an open source automation service with a web console, command line tools and a WebAPI. Prior to version 3.3.14 and version 3.4.3, an authorized user can upload a zip-format plugin with a crafted plugin.yaml, or a crafted aclpolicy yaml file, or upload an untrusted project archive with a crafted aclpolicy yaml file, that can cause the server to run untrusted code on Rundeck Community or Enterprise Edition. An authenticated user can make a POST request, that can cause the server to run untrusted code on Rundeck Enterprise Edition. The zip-format plugin issues requires authentication and authorization to these access levels, and affects all Rundeck editions:`admin` level access to the `system` resource type. The ACL Policy yaml file upload issues requires authentication and authorization to these access levels, and affects all Rundeck editions: `create` `update` or `admin` level access to a `project_acl` resource, and/or`create` `update` or `admin` level access to the `system_acl` resource. The unauthorized POST request requires authentication, but no specific authorization, and affects Rundeck Enterprise only. Patches are available in versions 3.4.3, 3.3.14","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","score":8.8},"cwes":["CWE-502"],"references":["https://github.com/rundeck/rundeck/commit/850d12e21d22833bc148b7f458d7cb5949f829b6","https://github.com/rundeck/rundeck/security/advisories/GHSA-q4rf-3fhx-88pf","https://github.com/rundeck/rundeck/commit/850d12e21d22833bc148b7f458d7cb5949f829b6","https://github.com/rundeck/rundeck/security/advisories/GHSA-q4rf-3fhx-88pf"],"products":["pagerduty:rundeck"],"source":"nvd","synced_at":"2026-10-19T21:21:57.125947417+00:00"},"epss":{"cve":"CVE-2021-39132","score":0.01688,"percentile":0.77039,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-q4rf-3fhx-88pf","url":"https://osv.dev/vulnerability/GHSA-q4rf-3fhx-88pf","summary":"YAML deserialization can run untrusted code","modified":"2026-07-08T06:27:28.787153892Z","packages":[{"ecosystem":"Maven","name":"org.rundeck:rundeck-core","purl":"pkg:maven/org.rundeck/rundeck-core","ranges":[">=3.4.0 <3.4.3"],"fixed":["3.4.3"]},{"ecosystem":"Maven","name":"org.rundeck:rundeck-core","purl":"pkg:maven/org.rundeck/rundeck-core","ranges":["<3.3.14"],"fixed":["3.3.14"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}