{"cve":"CVE-2021-37678","nvd":{"published":"2021-08-12T23:15:08.190","modified":"2026-06-17T04:00:57.927","status":"Modified","description":"TensorFlow is an end-to-end open source platform for machine learning. In affected versions TensorFlow and Keras can be tricked to perform arbitrary code execution when deserializing a Keras model from YAML format. The [implementation](https://github.com/tensorflow/tensorflow/blob/460e000de3a83278fb00b61a16d161b1964f15f4/tensorflow/python/keras/saving/model_config.py#L66-L104) uses `yaml.unsafe_load` which can perform arbitrary code execution on the input. Given that YAML format support requires a significant amount of work, we have removed it for now. We have patched the issue in GitHub commit 23d6383eb6c14084a8fc3bdf164043b974818012. The fix will be included in TensorFlow 2.6.0. We will also cherrypick this commit on TensorFlow 2.5.1, TensorFlow 2.4.3, and TensorFlow 2.3.4, as these are also affected and still in supported range.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H","score":8.8},"cwes":["CWE-502"],"references":["https://github.com/tensorflow/tensorflow/commit/23d6383eb6c14084a8fc3bdf164043b974818012","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-r6jx-9g48-2r5r","https://github.com/tensorflow/tensorflow/commit/23d6383eb6c14084a8fc3bdf164043b974818012","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-r6jx-9g48-2r5r"],"products":["google:tensorflow"],"source":"nvd","synced_at":"2026-10-19T21:21:57.125947417+00:00"},"epss":{"cve":"CVE-2021-37678","score":0.00447,"percentile":0.38919,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-r6jx-9g48-2r5r","url":"https://osv.dev/vulnerability/GHSA-r6jx-9g48-2r5r","summary":"Arbitrary code execution due to YAML deserialization","modified":"2026-07-08T06:28:54.520334642Z","packages":[{"ecosystem":"PyPI","name":"tensorflow","purl":"pkg:pypi/tensorflow","ranges":["<2.3.4"],"fixed":["2.3.4"]},{"ecosystem":"PyPI","name":"tensorflow","purl":"pkg:pypi/tensorflow","ranges":[">=2.4.0 <2.4.3"],"fixed":["2.4.3"]},{"ecosystem":"PyPI","name":"tensorflow","purl":"pkg:pypi/tensorflow","ranges":[">=2.5.0 <2.5.1"],"fixed":["2.5.1"]},{"ecosystem":"PyPI","name":"tensorflow-cpu","purl":"pkg:pypi/tensorflow-cpu","ranges":["<2.3.4"],"fixed":["2.3.4"]},{"ecosystem":"PyPI","name":"tensorflow-cpu","purl":"pkg:pypi/tensorflow-cpu","ranges":[">=2.4.0 <2.4.3"],"fixed":["2.4.3"]},{"ecosystem":"PyPI","name":"tensorflow-cpu","purl":"pkg:pypi/tensorflow-cpu","ranges":[">=2.5.0 <2.5.1"],"fixed":["2.5.1"]},{"ecosystem":"PyPI","name":"tensorflow-gpu","purl":"pkg:pypi/tensorflow-gpu","ranges":["<2.3.4"],"fixed":["2.3.4"]},{"ecosystem":"PyPI","name":"tensorflow-gpu","purl":"pkg:pypi/tensorflow-gpu","ranges":[">=2.4.0 <2.4.3"],"fixed":["2.4.3"]},{"ecosystem":"PyPI","name":"tensorflow-gpu","purl":"pkg:pypi/tensorflow-gpu","ranges":[">=2.5.0 <2.5.1"],"fixed":["2.5.1"]}]},{"id":"PYSEC-2021-300","url":"https://osv.dev/vulnerability/PYSEC-2021-300","summary":"","modified":"2023-12-06T01:01:23.844286Z","packages":[{"ecosystem":"PyPI","name":"tensorflow","purl":"pkg:pypi/tensorflow","ranges":[">=2.3.0 <2.3.4",">=2.4.0 <2.4.3"],"fixed":["2.3.4","2.4.3"]}]},{"id":"PYSEC-2021-591","url":"https://osv.dev/vulnerability/PYSEC-2021-591","summary":"","modified":"2023-12-06T01:01:23.844286Z","packages":[{"ecosystem":"PyPI","name":"tensorflow-cpu","purl":"pkg:pypi/tensorflow-cpu","ranges":[">=2.3.0 <2.3.4",">=2.4.0 <2.4.3"],"fixed":["2.3.4","2.4.3"]}]},{"id":"PYSEC-2021-789","url":"https://osv.dev/vulnerability/PYSEC-2021-789","summary":"","modified":"2023-12-06T01:01:23.844286Z","packages":[{"ecosystem":"PyPI","name":"tensorflow-gpu","purl":"pkg:pypi/tensorflow-gpu","ranges":[">=2.3.0 <2.3.4",">=2.4.0 <2.4.3"],"fixed":["2.3.4","2.4.3"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}