{"cve":"CVE-2021-31671","nvd":{"published":"2021-04-27T03:15:07.647","modified":"2026-06-17T03:52:08.363","status":"Modified","description":"pgsync before 0.6.7 is affected by Information Disclosure of sensitive information. Syncing the schema with the --schema-first and --schema-only options is mishandled. For example, the sslmode connection parameter may be lost, which means that SSL would not be used.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","score":7.5},"cwes":["CWE-319"],"references":["https://github.com/ankane/pgsync/issues/121","https://github.com/ankane/pgsync/issues/121"],"products":["pgsync_project:pgsync"],"source":"nvd","synced_at":"2026-10-19T21:17:01.373894544+00:00"},"epss":{"cve":"CVE-2021-31671","score":0.00731,"percentile":0.54302,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-72rj-36qc-47g7","url":"https://osv.dev/vulnerability/GHSA-72rj-36qc-47g7","summary":"Pgsync Contains Cleartext Transmission of Sensitive Information","modified":"2024-02-16T08:16:40.229764Z","packages":[{"ecosystem":"RubyGems","name":"pgsync","purl":"pkg:gem/pgsync","ranges":["<0.6.7"],"fixed":["0.6.7"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}