{"cve":"CVE-2021-24040","nvd":{"published":"2021-09-10T22:15:07.443","modified":"2026-06-17T03:39:12.283","status":"Modified","description":"Due to use of unsafe YAML deserialization logic, an attacker with the ability to modify local YAML configuration files could provide malicious input, resulting in remote code execution or similar risks. This issue affects ParlAI prior to v1.1.0.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8},"cwes":["CWE-502"],"references":["http://packetstormsecurity.com/files/164136/Facebook-ParlAI-1.0.0-Code-Execution-Deserialization.html","https://github.com/facebookresearch/ParlAI/releases/tag/v1.1.0","https://github.com/facebookresearch/ParlAI/security/advisories/GHSA-m87f-9fvv-2mgg","http://packetstormsecurity.com/files/164136/Facebook-ParlAI-1.0.0-Code-Execution-Deserialization.html","https://github.com/facebookresearch/ParlAI/releases/tag/v1.1.0"],"products":["facebook:parlai"],"source":"nvd","synced_at":"2026-10-19T21:23:41.316049955+00:00"},"epss":{"cve":"CVE-2021-24040","score":0.17353,"percentile":0.97115,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-m87f-9fvv-2mgg","url":"https://osv.dev/vulnerability/GHSA-m87f-9fvv-2mgg","summary":"Deserialization of Untrusted Data in parlai","modified":"2026-07-08T06:29:18.479936919Z","packages":[{"ecosystem":"PyPI","name":"parlai","purl":"pkg:pypi/parlai","ranges":["<1.1.0"],"fixed":["1.1.0"]}]},{"id":"GHSA-mwgj-7x7j-6966","url":"https://osv.dev/vulnerability/GHSA-mwgj-7x7j-6966","summary":"Deserialization of Untrusted Data in ParlAI","modified":"2024-12-04T05:39:38.595706Z","packages":[{"ecosystem":"PyPI","name":"parlai","purl":"pkg:pypi/parlai","ranges":["<1.1.0"],"fixed":["1.1.0"]}]},{"id":"PYSEC-2021-330","url":"https://osv.dev/vulnerability/PYSEC-2021-330","summary":"","modified":"2026-07-09T16:45:06.451893641Z","packages":[{"ecosystem":"PyPI","name":"parlai","purl":"pkg:pypi/parlai","ranges":["<1.1.0"],"fixed":["1.1.0"]}]},{"id":"PYSEC-2021-334","url":"https://osv.dev/vulnerability/PYSEC-2021-334","summary":"","modified":"2023-11-08T04:05:14.356894Z","packages":[{"ecosystem":"PyPI","name":"parlai","purl":"pkg:pypi/parlai","ranges":["<1.1.0"],"fixed":["1.1.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}