{"cve":"CVE-2021-23840","nvd":{"published":"2021-02-16T17:15:13.300","modified":"2026-06-17T03:38:54.593","status":"Modified","description":"Calls to EVP_CipherUpdate, EVP_EncryptUpdate and EVP_DecryptUpdate may overflow the output length argument in some cases where the input length is close to the maximum permissable length for an integer on the platform. In such cases the return value from the function call will be 1 (indicating success), but the output length value will be negative. This could cause applications to behave incorrectly or crash. OpenSSL versions 1.1.1i and below are affected by this issue. Users of these versions should upgrade to OpenSSL 1.1.1j. OpenSSL versions 1.0.2x and below are affected by this issue. However OpenSSL 1.0.2 is out of support and no longer receiving public updates. Premium support customers of OpenSSL 1.0.2 should upgrade to 1.0.2y. Other users should upgrade to 1.1.1j. Fixed in OpenSSL 1.1.1j (Affected 1.1.1-1.1.1i). Fixed in OpenSSL 1.0.2y (Affected 1.0.2-1.0.2x).","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","score":7.5},"cwes":["CWE-190"],"references":["https://cert-portal.siemens.com/productcert/pdf/ssa-389290.pdf","https://git.openssl.org/gitweb/?p=openssl.git%3Ba=commitdiff%3Bh=6a51b9e1d0cf0bf8515f7201b68fb0a3482b3dc1","https://git.openssl.org/gitweb/?p=openssl.git%3Ba=commitdiff%3Bh=9b1129239f3ebb1d1c98ce9ed41d5c9476c47cb2","https://kb.pulsesecure.net/articles/Pulse_Security_Advisories/SA44846","https://kc.mcafee.com/corporate/index?page=content&id=SB10366"],"products":["debian:debian_linux","fujitsu:m10-1_firmware","fujitsu:m10-4_firmware","fujitsu:m10-4s_firmware","fujitsu:m12-1_firmware","fujitsu:m12-2_firmware","fujitsu:m12-2s_firmware","mcafee:epolicy_orchestrator","nodejs:node.js","openssl:openssl","oracle:business_intelligence","oracle:communications_cloud_native_core_policy","oracle:enterprise_manager_for_storage_management","oracle:enterprise_manager_ops_center","oracle:graalvm","oracle:jd_edwards_enterpriseone_tools","oracle:jd_edwards_world_security","oracle:mysql_server","oracle:nosql_database","tenable:log_correlation_engine","tenable:nessus_network_monitor"],"source":"nvd","synced_at":"2026-10-19T21:15:50.279857260+00:00"},"epss":{"cve":"CVE-2021-23840","score":0.50732,"percentile":0.98921,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-qgm6-9472-pwq7","url":"https://osv.dev/vulnerability/GHSA-qgm6-9472-pwq7","summary":"Integer Overflow in openssl-src","modified":"2024-12-16T15:27:07.565493Z","packages":[{"ecosystem":"crates.io","name":"openssl-src","purl":"pkg:cargo/openssl-src","ranges":["<111.14.0"],"fixed":["111.14.0"]}]},{"id":"RUSTSEC-2021-0057","url":"https://osv.dev/vulnerability/RUSTSEC-2021-0057","summary":"Integer overflow in CipherUpdate","modified":"2024-12-16T15:27:07.565493Z","packages":[{"ecosystem":"crates.io","name":"openssl-src","purl":"pkg:cargo/openssl-src","ranges":[">=0.0.0-0 <111.14.0"],"fixed":["111.14.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}