{"cve":"CVE-2021-23447","nvd":{"published":"2021-10-07T17:15:08.087","modified":"2026-06-17T03:38:46.800","status":"Modified","description":"This affects the package teddy before 0.5.9. A type confusion vulnerability can be used to bypass input sanitization when the model content is an array (instead of a string).","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","score":6.1},"cwes":["CWE-843"],"references":["https://github.com/rooseveltframework/teddy/pull/518","https://github.com/rooseveltframework/teddy/releases/tag/0.5.9","https://snyk.io/vuln/SNYK-JS-TEDDY-1579557","https://github.com/rooseveltframework/teddy/pull/518","https://github.com/rooseveltframework/teddy/releases/tag/0.5.9"],"products":["teddy_project:teddy"],"source":"nvd","synced_at":"2026-10-19T21:23:41.316049955+00:00"},"epss":{"cve":"CVE-2021-23447","score":0.01128,"percentile":0.66357,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-5f38-9jw2-6r6h","url":"https://osv.dev/vulnerability/GHSA-5f38-9jw2-6r6h","summary":"Cross-site Scripting in teddy","modified":"2026-07-08T06:49:51.584010565Z","packages":[{"ecosystem":"npm","name":"teddy","purl":"pkg:npm/teddy","ranges":["<0.5.9"],"fixed":["0.5.9"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}