{"cve":"CVE-2021-23443","nvd":{"published":"2021-09-21T17:15:09.297","modified":"2026-06-17T03:38:46.313","status":"Modified","description":"This affects the package edge.js before 5.3.2. A type confusion vulnerability can be used to bypass input sanitization when the input to be rendered is an array (instead of a string or a SafeValue), even if {{ }} are used.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","score":6.1},"cwes":["CWE-843"],"references":["https://github.com/edge-js/edge/commit/fa2c7fde86327aeae232752e89a6e37e2e469e21","https://snyk.io/vuln/SNYK-JS-EDGEJS-1579556","https://github.com/edge-js/edge/commit/fa2c7fde86327aeae232752e89a6e37e2e469e21","https://snyk.io/vuln/SNYK-JS-EDGEJS-1579556"],"products":["adonisjs:edge"],"source":"nvd","synced_at":"2026-10-19T21:23:41.316049955+00:00"},"epss":{"cve":"CVE-2021-23443","score":0.00906,"percentile":0.59863,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-55r9-7mf8-m382","url":"https://osv.dev/vulnerability/GHSA-55r9-7mf8-m382","summary":"Cross-site Scripting in edge.js","modified":"2026-07-08T06:49:47.641734815Z","packages":[{"ecosystem":"npm","name":"edge.js","purl":"pkg:npm/edge.js","ranges":["<5.3.2"],"fixed":["5.3.2"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}