{"cve":"CVE-2021-21677","nvd":{"published":"2021-08-31T14:15:25.447","modified":"2026-06-17T03:35:58.857","status":"Modified","description":"Jenkins Code Coverage API Plugin 1.4.0 and earlier does not apply Jenkins JEP-200 deserialization protection to Java objects it deserializes from disk, resulting in a remote code execution vulnerability.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","score":8.8},"cwes":["CWE-502"],"references":["http://www.openwall.com/lists/oss-security/2021/08/31/1","https://www.jenkins.io/security/advisory/2021-08-31/#SECURITY-2376","http://www.openwall.com/lists/oss-security/2021/08/31/1","https://www.jenkins.io/security/advisory/2021-08-31/#SECURITY-2376"],"products":["jenkins:code_coverage_api"],"source":"nvd","synced_at":"2026-10-19T21:21:57.125947417+00:00"},"epss":{"cve":"CVE-2021-21677","score":0.02213,"percentile":0.82622,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-58pr-hprx-7hg6","url":"https://osv.dev/vulnerability/GHSA-58pr-hprx-7hg6","summary":"RCE vulnerability in Jenkins Code Coverage API Plugin","modified":"2024-02-16T08:22:02.827686Z","packages":[{"ecosystem":"Maven","name":"io.jenkins.plugins:code-coverage-api","purl":"pkg:maven/io.jenkins.plugins/code-coverage-api","ranges":["<1.4.1"],"fixed":["1.4.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}