{"cve":"CVE-2021-21668","nvd":{"published":"2021-06-16T14:15:08.610","modified":"2026-06-17T03:35:57.870","status":"Modified","description":"Jenkins Scriptler Plugin 3.1 and earlier does not escape script content, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Scriptler/Configure permission.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","score":5.4},"cwes":["CWE-79"],"references":["http://www.openwall.com/lists/oss-security/2021/06/16/3","https://www.jenkins.io/security/advisory/2021-06-16/#SECURITY-2390","http://www.openwall.com/lists/oss-security/2021/06/16/3","https://www.jenkins.io/security/advisory/2021-06-16/#SECURITY-2390"],"products":["jenkins:scriptler"],"source":"nvd","synced_at":"2026-10-19T21:20:07.141963181+00:00"},"epss":{"cve":"CVE-2021-21668","score":0.76016,"percentile":0.9953,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-5c6c-w4c4-vgvx","url":"https://osv.dev/vulnerability/GHSA-5c6c-w4c4-vgvx","summary":"Stored XSS vulnerability in Jenkins Scriptler Plugin","modified":"2024-02-16T08:08:06.830821Z","packages":[{"ecosystem":"Maven","name":"org.jenkins-ci.plugins:scriptler","purl":"pkg:maven/org.jenkins-ci.plugins/scriptler","ranges":["<3.2"],"fixed":["3.2"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}