{"cve":"CVE-2021-21618","nvd":{"published":"2021-02-24T16:15:14.897","modified":"2026-06-17T03:35:52.927","status":"Modified","description":"Jenkins Repository Connector Plugin 2.0.2 and earlier does not escape parameter names and descriptions for past builds, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","score":5.4},"cwes":["CWE-79"],"references":["https://www.jenkins.io/security/advisory/2021-02-24/#SECURITY-2183","https://www.jenkins.io/security/advisory/2021-02-24/#SECURITY-2183"],"products":["jenkins:repository_connector"],"source":"nvd","synced_at":"2026-10-19T21:15:50.279857260+00:00"},"epss":{"cve":"CVE-2021-21618","score":0.79479,"percentile":0.99603,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-hg2w-3c4j-jjwm","url":"https://osv.dev/vulnerability/GHSA-hg2w-3c4j-jjwm","summary":"Stored XSS vulnerability in Jenkins Repository Connector Plugin","modified":"2024-02-16T08:22:44.493126Z","packages":[{"ecosystem":"Maven","name":"org.jenkins-ci.plugins:repository-connector","purl":"pkg:maven/org.jenkins-ci.plugins/repository-connector","ranges":["<2.0.3"],"fixed":["2.0.3"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}