{"cve":"CVE-2021-21616","nvd":{"published":"2021-02-24T16:15:14.663","modified":"2026-06-17T03:35:52.723","status":"Modified","description":"Jenkins Active Choices Plugin 2.5.2 and earlier does not escape reference parameter values, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Job/Configure permission.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N","score":4.6},"cwes":["CWE-79"],"references":["http://www.openwall.com/lists/oss-security/2021/02/24/3","https://www.jenkins.io/security/advisory/2021-02-24/#SECURITY-2192","http://www.openwall.com/lists/oss-security/2021/02/24/3","https://www.jenkins.io/security/advisory/2021-02-24/#SECURITY-2192"],"products":["jenkins:active_choices"],"source":"nvd","synced_at":"2026-10-19T21:15:50.279857260+00:00"},"epss":{"cve":"CVE-2021-21616","score":0.76218,"percentile":0.99536,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-4f6x-g5vh-8jm5","url":"https://osv.dev/vulnerability/GHSA-4f6x-g5vh-8jm5","summary":"Stored XSS vulnerability in Jenkins Active Choices Plugin","modified":"2024-02-16T08:23:01.036437Z","packages":[{"ecosystem":"Maven","name":"org.biouno:uno-choice","purl":"pkg:maven/org.biouno/uno-choice","ranges":["<2.5.3"],"fixed":["2.5.3"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}