{"cve":"CVE-2021-21389","nvd":{"published":"2021-03-26T21:15:13.520","modified":"2026-06-17T03:35:28.250","status":"Modified","description":"BuddyPress is an open source WordPress plugin to build a community site. In releases of BuddyPress from 5.0.0 before 7.2.1 it's possible for a non-privileged, regular user to obtain administrator rights by exploiting an issue in the REST API members endpoint. The vulnerability has been fixed in BuddyPress 7.2.1. Existing installations of the plugin should be updated to this version to mitigate the issue.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","score":8.8},"cwes":["CWE-863"],"references":["https://buddypress.org/2021/03/buddypress-7-2-1-security-release/","https://codex.buddypress.org/releases/version-7-2-1/","https://github.com/buddypress/BuddyPress/security/advisories/GHSA-m6j4-8r7p-wpp3","https://buddypress.org/2021/03/buddypress-7-2-1-security-release/","https://codex.buddypress.org/releases/version-7-2-1/"],"products":["buddypress:buddypress"],"source":"nvd","synced_at":"2026-10-19T21:17:01.373894544+00:00"},"epss":{"cve":"CVE-2021-21389","score":0.14811,"percentile":0.96686,"date":"2026-10-31"},"kev":null,"osv":[],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}