{"cve":"CVE-2021-21337","nvd":{"published":"2021-03-08T21:15:16.807","modified":"2026-06-17T03:35:19.603","status":"Modified","description":"Products.PluggableAuthService is a pluggable Zope authentication and authorization framework. In Products.PluggableAuthService before version 2.6.0 there is an open redirect vulnerability. A maliciously crafted link to the login form and login functionality could redirect the browser to a different website. The problem has been fixed in version 2.6.1. Depending on how you have installed Products.PluggableAuthService, you should change the buildout version pin to `2.6.1` and re-run the buildout, or if you used `pip` simply do `pip install \"Products.PluggableAuthService>=2.6.1\".","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","score":6.1},"cwes":["CWE-601"],"references":["http://packetstormsecurity.com/files/162911/Products.PluggableAuthService-2.6.0-Open-Redirect.html","https://github.com/zopefoundation/Products.PluggableAuthService/commit/7eead067898852ebd3e0f143bc51295928528dfa","https://github.com/zopefoundation/Products.PluggableAuthService/security/advisories/GHSA-p44j-xrqg-4xrr","https://pypi.org/project/Products.PluggableAuthService/","http://packetstormsecurity.com/files/162911/Products.PluggableAuthService-2.6.0-Open-Redirect.html"],"products":["zope:products.pluggableauthservice"],"source":"nvd","synced_at":"2026-10-19T21:15:50.279857260+00:00"},"epss":{"cve":"CVE-2021-21337","score":0.08443,"percentile":0.95004,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-p44j-xrqg-4xrr","url":"https://osv.dev/vulnerability/GHSA-p44j-xrqg-4xrr","summary":"URL Redirection to Untrusted Site ('Open Redirect') in Products.PluggableAuthService","modified":"2026-07-08T06:27:50.342932580Z","packages":[{"ecosystem":"PyPI","name":"products-pluggableauthservice","purl":"pkg:pypi/products-pluggableauthservice","ranges":["<2.6.1"],"fixed":["2.6.1"]}]},{"id":"PYSEC-2021-45","url":"https://osv.dev/vulnerability/PYSEC-2021-45","summary":"","modified":"2023-11-08T04:04:41.823807Z","packages":[{"ecosystem":"PyPI","name":"products-pluggableauthservice","purl":"pkg:pypi/products-pluggableauthservice","ranges":["<2.6.1"],"fixed":["2.6.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}