{"cve":"CVE-2021-21334","nvd":{"published":"2021-03-10T22:15:12.183","modified":"2026-06-17T03:35:19.197","status":"Modified","description":"In containerd (an industry-standard container runtime) before versions 1.3.10 and 1.4.4, containers launched through containerd's CRI implementation (through Kubernetes, crictl, or any other pod/container client that uses the containerd CRI service) that share the same image may receive incorrect environment variables, including values that are defined for other containers. If the affected containers have different security contexts, this may allow sensitive information to be unintentionally shared. If you are not using containerd's CRI implementation (through one of the mechanisms described above), you are not vulnerable to this issue. If you are not launching multiple containers or Kubernetes pods from the same image which have different environment variables, you are not vulnerable to this issue. If you are not launching multiple containers or Kubernetes pods from the same image in rapid succession, you have reduced likelihood of being vulnerable to this issue This vulnerability has been fixed in containerd 1.3.10 and containerd 1.4.4. Users should update to these versions.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:N/A:N","score":6.3},"cwes":["CWE-668"],"references":["https://github.com/containerd/containerd/commit/05f951a3781f4f2c1911b05e61c160e9c30eaa8e","https://github.com/containerd/containerd/releases/tag/v1.3.10","https://github.com/containerd/containerd/releases/tag/v1.4.4","https://github.com/containerd/containerd/security/advisories/GHSA-6g2q-w5j3-fwh4","https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/KUE2Z2ZUWBHRU36ZGBD2YSJCYB6ELPXE/"],"products":["fedoraproject:fedora","linuxfoundation:containerd"],"source":"nvd","synced_at":"2026-10-19T21:15:50.279857260+00:00"},"epss":{"cve":"CVE-2021-21334","score":0.01947,"percentile":0.80204,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-6g2q-w5j3-fwh4","url":"https://osv.dev/vulnerability/GHSA-6g2q-w5j3-fwh4","summary":"containerd environment variable leak","modified":"2026-09-10T03:50:04.845087799Z","packages":[{"ecosystem":"Go","name":"github.com/containerd/containerd","purl":"pkg:golang/github.com/containerd/containerd","ranges":[">=1.4.0 <1.4.4"],"fixed":["1.4.4"]},{"ecosystem":"Go","name":"github.com/containerd/containerd","purl":"pkg:golang/github.com/containerd/containerd","ranges":["<1.3.10"],"fixed":["1.3.10"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}