{"cve":"CVE-2021-21316","nvd":{"published":"2021-02-16T18:15:12.490","modified":"2026-06-17T03:35:16.920","status":"Modified","description":"less-openui5 is an npm package which enables building OpenUI5 themes with Less.js. In less-openui5 before version 0.10., when processing theming resources (i.e. `*.less` files) with less-openui5 that originate from an untrusted source, those resources might contain JavaScript code which will be executed in the context of the build process. While this is a feature of the Less.js library it is an unexpected behavior in the context of OpenUI5 and SAPUI5 development. Especially in the context of UI5 Tooling which relies on less-openui5. An attacker might create a library or theme-library containing a custom control or theme, hiding malicious JavaScript code in one of the .less files. Refer to the referenced GHSA-3crj-w4f5-gwh4 for examples. Starting with Less.js version 3.0.0, the Inline JavaScript feature is disabled by default. less-openui5 however currently uses a fork of Less.js v1.6.3. Note that disabling the Inline JavaScript feature in Less.js versions 1.x, still evaluates code has additional double codes around it. We decided to remove the inline JavaScript evaluation feature completely from the code of our Less.js fork. This fix is available in less-openui5 version 0.10.0.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","score":7.8},"cwes":["CWE-74"],"references":["http://lesscss.org/usage/#less-options-enable-inline-javascript-deprecated-","https://github.com/SAP/less-openui5/commit/c0d3a8572974a20ea6cee42da11c614a54f100e8","https://github.com/SAP/less-openui5/releases/tag/v0.10.0","https://github.com/SAP/less-openui5/security/advisories/GHSA-3crj-w4f5-gwh4","https://www.npmjs.com/package/less-openui5"],"products":["less-openui5_project:less-openui5"],"source":"nvd","synced_at":"2026-10-19T21:15:50.279857260+00:00"},"epss":{"cve":"CVE-2021-21316","score":0.00988,"percentile":0.62465,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-3crj-w4f5-gwh4","url":"https://osv.dev/vulnerability/GHSA-3crj-w4f5-gwh4","summary":"Processing untrusted theming resources might execute arbitrary code (ACE)","modified":"2026-07-08T06:28:29.484614664Z","packages":[{"ecosystem":"npm","name":"less-openui5","purl":"pkg:npm/less-openui5","ranges":["<0.10.0"],"fixed":["0.10.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}