{"cve":"CVE-2021-20259","nvd":{"published":"2021-06-07T21:15:07.950","modified":"2026-06-17T03:33:33.573","status":"Modified","description":"A flaw was found in the Foreman project. The Proxmox compute resource exposes the password through the API to an authenticated local attacker with view_hosts permission. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability. Versions before foreman_fog_proxmox 0.13.1 are affected","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","score":7.8},"cwes":["CWE-200"],"references":["https://bugzilla.redhat.com/show_bug.cgi?id=1932144","https://bugzilla.redhat.com/show_bug.cgi?id=1932144"],"products":["theforeman:foremanfogproxmox"],"source":"nvd","synced_at":"2026-10-19T21:20:07.141963181+00:00"},"epss":{"cve":"CVE-2021-20259","score":0.00273,"percentile":0.19709,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-f2rp-4rv7-fc95","url":"https://osv.dev/vulnerability/GHSA-f2rp-4rv7-fc95","summary":"Exposure of Sensitive Information to an Unauthorized Actor in foreman_fog_proxmox","modified":"2023-11-08T04:04:36.135332Z","packages":[{"ecosystem":"RubyGems","name":"foreman_fog_proxmox","purl":"pkg:gem/foreman_fog_proxmox","ranges":["<0.13.1"],"fixed":["0.13.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}