{"cve":"CVE-2021-20195","nvd":{"published":"2021-05-28T11:15:07.867","modified":"2026-06-17T03:33:27.113","status":"Modified","description":"A flaw was found in keycloak in versions before 13.0.0. A Self Stored XSS attack vector escalating to a complete account takeover is possible due to user-supplied data fields not being properly encoded and Javascript code being used to process the data. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H","score":9.6},"cwes":["CWE-116","CWE-20"],"references":["https://bugzilla.redhat.com/show_bug.cgi?id=1919143","https://bugzilla.redhat.com/show_bug.cgi?id=1919143"],"products":["redhat:keycloak"],"source":"nvd","synced_at":"2026-10-19T21:18:09.669877188+00:00"},"epss":{"cve":"CVE-2021-20195","score":0.01249,"percentile":0.69382,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-q6w2-89hq-hq27","url":"https://osv.dev/vulnerability/GHSA-q6w2-89hq-hq27","summary":"keycloak Self Stored Cross-site Scripting vulnerability","modified":"2023-11-08T04:04:35.407021Z","packages":[{"ecosystem":"Maven","name":"org.keycloak:keycloak-core","purl":"pkg:maven/org.keycloak/keycloak-core","ranges":["<13.0.0"],"fixed":["13.0.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}