{"cve":"CVE-2021-20191","nvd":{"published":"2021-05-26T21:15:08.193","modified":"2026-06-17T03:33:26.780","status":"Modified","description":"A flaw was found in ansible. Credentials, such as secrets, are being disclosed in console log by default and not protected by no_log feature when using those modules. An attacker can take advantage of this information to steal those credentials. The highest threat from this vulnerability is to data confidentiality. Versions before ansible 2.9.18 are affected.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","score":5.5},"cwes":["CWE-532"],"references":["https://bugzilla.redhat.com/show_bug.cgi?id=1916813","https://lists.debian.org/debian-lts-announce/2023/12/msg00018.html","https://bugzilla.redhat.com/show_bug.cgi?id=1916813","https://lists.debian.org/debian-lts-announce/2023/12/msg00018.html"],"products":["oracle:virtualization","redhat:ansible","redhat:ansible_tower","redhat:cisco_nx-os_collection","redhat:community_general_collection","redhat:community_network_collection","redhat:docker_community_collection","redhat:google_cloud_platform_ansible_collection"],"source":"nvd","synced_at":"2026-10-19T21:18:09.669877188+00:00"},"epss":{"cve":"CVE-2021-20191","score":0.00349,"percentile":0.28604,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-8f4m-hccc-8qph","url":"https://osv.dev/vulnerability/GHSA-8f4m-hccc-8qph","summary":"Insertion of Sensitive Information into Log File in ansible","modified":"2024-09-10T22:06:37.487770Z","packages":[{"ecosystem":"PyPI","name":"ansible","purl":"pkg:pypi/ansible","ranges":[">=2.9.0a1 <2.9.18rc1"],"fixed":["2.9.18rc1"]},{"ecosystem":"PyPI","name":"ansible","purl":"pkg:pypi/ansible","ranges":["<2.8.19rc1"],"fixed":["2.8.19rc1"]},{"ecosystem":"PyPI","name":"ansible","purl":"pkg:pypi/ansible","ranges":[">=2.10.0a1 <2.10.7"],"fixed":["2.10.7"]}]},{"id":"PYSEC-2021-124","url":"https://osv.dev/vulnerability/PYSEC-2021-124","summary":"","modified":"2023-11-08T04:04:35.345555Z","packages":[{"ecosystem":"PyPI","name":"ansible","purl":"pkg:pypi/ansible","ranges":["<2.8.19",">=2.9.0 <2.9.18",">=2.10.0 <2.10.7"],"fixed":["2.8.19","2.9.18","2.10.7"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}