{"cve":"CVE-2020-8176","nvd":{"published":"2020-07-02T19:15:12.590","modified":"2026-06-17T03:25:59.717","status":"Modified","description":"A cross-site scripting vulnerability exists in koa-shopify-auth v3.1.61-v3.1.62 that allows an attacker to inject JS payloads into the `shop` parameter on the `/shopify/auth/enable_cookies` endpoint.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","score":6.1},"cwes":["CWE-79"],"references":["https://github.com/Shopify/quilt/pull/1455","https://hackerone.com/reports/881409","https://github.com/Shopify/quilt/pull/1455","https://hackerone.com/reports/881409"],"products":["shopify:koa-shopify-auth"],"source":"nvd","synced_at":"2026-10-19T21:06:22.076270124+00:00"},"epss":{"cve":"CVE-2020-8176","score":0.00984,"percentile":0.62345,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-jqh7-w5pr-cr56","url":"https://osv.dev/vulnerability/GHSA-jqh7-w5pr-cr56","summary":"Cross-site scripting in @shopify/koa-shopify-auth","modified":"2023-11-08T04:04:15.234899Z","packages":[{"ecosystem":"npm","name":"@shopify/koa-shopify-auth","purl":"pkg:npm/%40shopify/koa-shopify-auth","ranges":[">=3.1.61 <3.1.63"],"fixed":["3.1.63"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}