{"cve":"CVE-2020-8127","nvd":{"published":"2020-02-28T20:15:11.537","modified":"2026-06-17T03:25:54.477","status":"Modified","description":"Insufficient validation in cross-origin communication (postMessage) in reveal.js version 3.9.1 and earlier allow attackers to perform cross-site scripting attacks.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","score":6.1},"cwes":["CWE-79"],"references":["https://hackerone.com/reports/691977","https://hackerone.com/reports/691977"],"products":["revealjs:reveal.js"],"source":"nvd","synced_at":"2026-10-19T21:02:53.949909883+00:00"},"epss":{"cve":"CVE-2020-8127","score":0.01197,"percentile":0.68116,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-6vwx-mwp8-fh44","url":"https://osv.dev/vulnerability/GHSA-6vwx-mwp8-fh44","summary":"Cross-site Scripting in reveal.js","modified":"2023-11-08T04:04:13.651442Z","packages":[{"ecosystem":"npm","name":"reveal.js","purl":"pkg:npm/reveal.js","ranges":["<3.9.2"],"fixed":["3.9.2"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}