{"cve":"CVE-2020-7789","nvd":{"published":"2020-12-11T10:15:12.423","modified":"2026-06-17T03:25:26.927","status":"Modified","description":"This affects the package node-notifier before 9.0.0. It allows an attacker to run arbitrary commands on Linux machines due to the options params not being sanitised when being passed an array.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L","score":5.6},"cwes":["CWE-78"],"references":["https://github.com/mikaelbr/node-notifier/blob/master/lib/utils.js%23L303","https://snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-1050371","https://snyk.io/vuln/SNYK-JS-NODENOTIFIER-1035794","https://github.com/mikaelbr/node-notifier/blob/master/lib/utils.js%23L303","https://snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-1050371"],"products":["node-notifier_project:node-notifier"],"source":"nvd","synced_at":"2026-10-19T21:12:09.559580076+00:00"},"epss":{"cve":"CVE-2020-7789","score":0.01587,"percentile":0.75604,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-5fw9-fq32-wv5p","url":"https://osv.dev/vulnerability/GHSA-5fw9-fq32-wv5p","summary":"OS Command Injection in node-notifier","modified":"2025-01-14T08:56:52.296116Z","packages":[{"ecosystem":"npm","name":"node-notifier","purl":"pkg:npm/node-notifier","ranges":["<8.0.1"],"fixed":["8.0.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}