{"cve":"CVE-2020-5236","nvd":{"published":"2020-02-04T03:15:10.750","modified":"2026-06-17T03:21:05.140","status":"Modified","description":"Waitress version 1.4.2 allows a DOS attack When waitress receives a header that contains invalid characters. When a header like \"Bad-header: xxxxxxxxxxxxxxx\\x10\" is received, it will cause the regular expression engine to catastrophically backtrack causing the process to use 100% CPU time and blocking any other interactions. This allows an attacker to send a single request with an invalid header and take the service offline. This issue was introduced in version 1.4.2 when the regular expression was updated to attempt to match the behaviour required by errata associated with RFC7230. The regular expression that is used to validate incoming headers has been updated in version 1.4.3, it is recommended that people upgrade to the new version of Waitress as soon as possible.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H","score":6.5},"cwes":["CWE-400"],"references":["https://github.com/Pylons/waitress/commit/6e46f9e3f014d64dd7d1e258eaf626e39870ee1f","https://github.com/Pylons/waitress/security/advisories/GHSA-73m2-3pwg-5fgc","https://github.com/Pylons/waitress/commit/6e46f9e3f014d64dd7d1e258eaf626e39870ee1f","https://github.com/Pylons/waitress/security/advisories/GHSA-73m2-3pwg-5fgc"],"products":["agendaless:waitress"],"source":"nvd","synced_at":"2026-10-19T21:01:01.339895972+00:00"},"epss":{"cve":"CVE-2020-5236","score":0.02363,"percentile":0.8379,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-73m2-3pwg-5fgc","url":"https://osv.dev/vulnerability/GHSA-73m2-3pwg-5fgc","summary":"Catastrophic backtracking in regex allows Denial of Service in Waitress","modified":"2026-09-10T03:49:25.209471044Z","packages":[{"ecosystem":"PyPI","name":"waitress","purl":"pkg:pypi/waitress","ranges":[">=1.4.2 <1.4.3"],"fixed":["1.4.3"]}]},{"id":"PYSEC-2020-155","url":"https://osv.dev/vulnerability/PYSEC-2020-155","summary":"","modified":"2023-11-08T04:03:52.479840Z","packages":[{"ecosystem":"PyPI","name":"waitress","purl":"pkg:pypi/waitress","ranges":["<1.4.3"],"fixed":["1.4.3"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}