{"cve":"CVE-2020-4043","nvd":{"published":"2020-06-10T20:15:14.483","modified":"2026-06-17T03:19:28.470","status":"Modified","description":"phpMussel from versions 1.0.0 and less than 1.6.0 has an unserialization vulnerability in PHP's phar wrapper. Uploading a specially crafted file to an affected version allows arbitrary code execution (discovered, tested, and confirmed by myself), so the risk factor should be regarded as very high. Newer phpMussel versions don't use PHP's phar wrapper, and are therefore unaffected. This has been fixed in version 1.6.0.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8},"cwes":["CWE-502"],"references":["https://github.com/phpMussel/phpMussel/commit/97f25973433921c1f953430f32d3081adc4851a4","https://github.com/phpMussel/phpMussel/issues/167","https://github.com/phpMussel/phpMussel/pull/173","https://github.com/phpMussel/phpMussel/security/advisories/GHSA-qr95-4mq5-r3fh","https://github.com/phpMussel/phpMussel/security/policy#currently-known-vulnerabilities"],"products":["phpmussel_project:phpmussel"],"source":"nvd","synced_at":"2026-10-19T21:05:42.039641217+00:00"},"epss":{"cve":"CVE-2020-4043","score":0.02597,"percentile":0.85332,"date":"2026-10-31"},"kev":null,"osv":[],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}