{"cve":"CVE-2020-28364","nvd":{"published":"2020-11-09T21:15:12.650","modified":"2026-06-17T03:10:20.010","status":"Modified","description":"A stored cross-site scripting (XSS) vulnerability affects the Web UI in Locust before 1.3.2, if the installation violates the usage expectations by exposing this UI to outside users.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","score":6.1},"cwes":["CWE-79"],"references":["https://docs.locust.io/en/stable/changelog.html","https://docs.locust.io/en/stable/changelog.html"],"products":["locust:locust"],"source":"nvd","synced_at":"2026-10-19T21:11:20.317016139+00:00"},"epss":{"cve":"CVE-2020-28364","score":0.00647,"percentile":0.51008,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-vqxw-9pg7-v7v9","url":"https://osv.dev/vulnerability/GHSA-vqxw-9pg7-v7v9","summary":"Locust Stored Cross-site Scripting Vulnerability","modified":"2024-09-30T17:00:13.368522Z","packages":[{"ecosystem":"PyPI","name":"locust","purl":"pkg:pypi/locust","ranges":["<1.3.2"],"fixed":["1.3.2"]}]},{"id":"PYSEC-2020-60","url":"https://osv.dev/vulnerability/PYSEC-2020-60","summary":"","modified":"2026-06-10T17:00:34.618482475Z","packages":[{"ecosystem":"PyPI","name":"locust","purl":"pkg:pypi/locust","ranges":["<1.3.2"],"fixed":["1.3.2"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}