{"cve":"CVE-2020-2280","nvd":{"published":"2020-09-23T14:15:13.103","modified":"2026-06-17T03:12:07.887","status":"Modified","description":"A cross-site request forgery (CSRF) vulnerability in Jenkins Warnings Plugin 5.0.1 and earlier allows attackers to execute arbitrary code.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","score":8.8},"cwes":["CWE-352"],"references":["http://www.openwall.com/lists/oss-security/2020/09/23/1","https://www.jenkins.io/security/advisory/2020-09-23/#SECURITY-2042","http://www.openwall.com/lists/oss-security/2020/09/23/1","https://www.jenkins.io/security/advisory/2020-09-23/#SECURITY-2042"],"products":["jenkins:warnings"],"source":"nvd","synced_at":"2026-10-19T21:09:53.489947993+00:00"},"epss":{"cve":"CVE-2020-2280","score":0.01082,"percentile":0.65175,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-q564-vvx8-9388","url":"https://osv.dev/vulnerability/GHSA-q564-vvx8-9388","summary":"CSRF vulnerability in Jenkins warnings Plugin allows remote code execution","modified":"2024-02-16T08:06:36.513973Z","packages":[{"ecosystem":"Maven","name":"org.jvnet.hudson.plugins:warnings","purl":"pkg:maven/org.jvnet.hudson.plugins/warnings","ranges":["<5.0.2"],"fixed":["5.0.2"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}