{"cve":"CVE-2020-2207","nvd":{"published":"2020-07-02T15:15:17.677","modified":"2026-06-17T03:11:59.570","status":"Modified","description":"Jenkins VncViewer Plugin 1.7 and earlier does not escape a parameter value in the checkVncServ form validation endpoint, resulting in a reflected cross-site scripting (XSS) vulnerability.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","score":6.1},"cwes":["CWE-79"],"references":["http://www.openwall.com/lists/oss-security/2020/07/02/7","https://jenkins.io/security/advisory/2020-07-02/#SECURITY-1776","http://www.openwall.com/lists/oss-security/2020/07/02/7","https://jenkins.io/security/advisory/2020-07-02/#SECURITY-1776"],"products":["jenkins:vncviewer"],"source":"nvd","synced_at":"2026-10-19T21:06:22.076270124+00:00"},"epss":{"cve":"CVE-2020-2207","score":0.00871,"percentile":0.58851,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-2j4h-cjgh-659v","url":"https://osv.dev/vulnerability/GHSA-2j4h-cjgh-659v","summary":"Reflected XSS vulnerability in Jenkins VncViewer Plugin","modified":"2024-02-16T08:18:00.525629Z","packages":[{"ecosystem":"Maven","name":"org.jenkins-ci.plugins:vncviewer","purl":"pkg:maven/org.jenkins-ci.plugins/vncviewer","ranges":["<1.8"],"fixed":["1.8"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}