{"cve":"CVE-2020-2193","nvd":{"published":"2020-06-03T13:15:10.773","modified":"2026-06-17T03:11:57.790","status":"Modified","description":"Jenkins ECharts API Plugin 4.7.0-3 and earlier does not escape the parser identifier when rendering charts, resulting in a stored cross-site scripting vulnerability.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","score":5.4},"cwes":["CWE-79"],"references":["http://www.openwall.com/lists/oss-security/2020/06/03/3","https://jenkins.io/security/advisory/2020-06-03/#SECURITY-1841","http://www.openwall.com/lists/oss-security/2020/06/03/3","https://jenkins.io/security/advisory/2020-06-03/#SECURITY-1841"],"products":["jenkins:echarts_api"],"source":"nvd","synced_at":"2026-10-19T21:05:42.039641217+00:00"},"epss":{"cve":"CVE-2020-2193","score":0.00735,"percentile":0.54446,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-x9rq-9h44-f84v","url":"https://osv.dev/vulnerability/GHSA-x9rq-9h44-f84v","summary":"Stored XSS vulnerability in Jenkins ECharts API Plugin","modified":"2023-11-08T04:02:55.991384Z","packages":[{"ecosystem":"Maven","name":"io.jenkins.plugins:echarts-api","purl":"pkg:maven/io.jenkins.plugins/echarts-api","ranges":["<4.7.0-4"],"fixed":["4.7.0-4"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}