{"cve":"CVE-2020-2173","nvd":{"published":"2020-04-07T13:15:13.633","modified":"2026-06-17T03:11:55.313","status":"Modified","description":"Jenkins Gatling Plugin 1.2.7 and earlier prevents Content-Security-Policy headers from being set for Gatling reports served by the plugin, resulting in an XSS vulnerability exploitable by users able to change report content.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","score":5.4},"cwes":["CWE-79"],"references":["http://www.openwall.com/lists/oss-security/2020/04/07/3","https://jenkins.io/security/advisory/2020-04-07/#SECURITY-1633","http://www.openwall.com/lists/oss-security/2020/04/07/3","https://jenkins.io/security/advisory/2020-04-07/#SECURITY-1633"],"products":["jenkins:gatling"],"source":"nvd","synced_at":"2026-10-19T21:03:08.679916934+00:00"},"epss":{"cve":"CVE-2020-2173","score":0.00705,"percentile":0.53368,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-hv53-qjg6-5pm9","url":"https://osv.dev/vulnerability/GHSA-hv53-qjg6-5pm9","summary":"XSS vulnerability in Jenkins Gatling Plugin","modified":"2023-11-08T04:02:54.773Z","packages":[{"ecosystem":"Maven","name":"org.jenkins-ci.plugins:gatling","purl":"pkg:maven/org.jenkins-ci.plugins/gatling","ranges":["<1.3.0"],"fixed":["1.3.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}